$re = '/^[A-Za-z]+$/m';
$str = 'aA4?asA8
A5V3asd,adwS5!
abacada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);