package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:records failed)$`)
var str = `TaskBlahBlah: [0] records failed`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}