$re = '~(?:records failed)$~';
$str = 'TaskBlahBlah: [0] records failed';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);