$re = '/^(?=[^\\\\\/]*(?:[\\\\\/][^\\\\\/]*){0,2}$)[\d\\\\\/]{5,10}$/m';
$str = '121123/\\3465346
5/\\3465346
3/\\\\\\01777
3\\017773\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);