re = /^(?=[^\\\/]*(?:[\\\/][^\\\/]*){0,2}$)[\d\\\/]{5,10}$/m
str = '121123/\\3465346
5/\\3465346
3/\\\\\\01777
3\\017773\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end