$re = '/(?<!\S)[A-Z](?:(?).)*[^\s@]+@[^\s@]+/m';
$str = 'This is a random sentence. This one is also random sentence but it contains an email address ---@---.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);