re = /(?<!\S)[A-Z](?:(?).)*[^\s@]+@[^\s@]+/m
str = 'This is a random sentence. This one is also random sentence but it contains an email address ---@---.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end