using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(int\s*|String\s*)[\[\]\w]*\s*[\,\)]";
string input = @"public int maxNumber ( int abf , int a123 , int abc48 , String a[] ) ;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}