// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(int\s*|String\s*)[\[\]\w]*\s*[\,\)]").unwrap();
let string = "public int maxNumber ( int abf , int a123 , int abc48 , String a[] ) ;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}