$re = '/(\b\w+\b)(?=(?:.*?\b\1\b){2,})/i';
$str = 'Hello my world
Hello my world, hello my world, hello my world
Hello my world, hello my world, hello my world, hello my world
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);