re = /(\b\w+\b)(?=(?:.*?\b\1\b){2,})/i
str = 'Hello my world
Hello my world, hello my world, hello my world
Hello my world, hello my world, hello my world, hello my world
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end