using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ersion ([^,]*)(,)? RELEASE";
string input = @"Version 03.06.07b.E, RELEASE SOFTWARE (fc1)
Version 03.06.07b.E RELEASE SOFTWARE (fc1)
version 1.3(2)ES3
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}