package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ersion ([^,]*)(,)? RELEASE`)
var str = `Version 03.06.07b.E, RELEASE SOFTWARE (fc1)
Version 03.06.07b.E RELEASE SOFTWARE (fc1)
version 1.3(2)ES3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}