package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w{3} [ :[:digit:]]{11}[._[:alnum:]-]+ kernel:( [ *[[:digit:]]+.[[:digit:]]+])?`)
var str = `Aug 1 09:33:49 samsung4-ubuntu kernel: [ 0.045109] pinctrl core: initialized pinctrl subsystem
Aug 1 09:33:50 samsung4-ubuntu kernel: [ 0.172476] Bluetooth: Core ver 2.22`
var substitution = "^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ kernel:( [ *[[:digit:]]+.[[:digit:]]+])?"
fmt.Println(re.ReplaceAllString(str, substitution))
}