re = /^\w{3} [ :[:digit:]]{11}[._[:alnum:]-]+ kernel:( [ *[[:digit:]]+.[[:digit:]]+])?/m
str = 'Aug 1 09:33:49 samsung4-ubuntu kernel: [ 0.045109] pinctrl core: initialized pinctrl subsystem
Aug 1 09:33:50 samsung4-ubuntu kernel: [ 0.172476] Bluetooth: Core ver 2.22'
subst = '^\\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ kernel:( [ *[[:digit:]]+.[[:digit:]]+])?'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result