package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/{2}\s*cin\s*>>(*SKIP)(*F)|\s*\bcin\s*>>`)
var str = `//cin >>x;
// cin >>x;
cin >>y;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}