$re = '~/{2}\s*cin\s*>>(*SKIP)(*F)|\s*\bcin\s*>>~';
$str = '//cin >>x;
// cin >>x;
cin >>y;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);