using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:{{|\$\|)(.*?)(?:}}|\$\|)";
string input = @"""This {{@is}} a $|test$| string with $|@string$| delimiters {{as}} follows""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}