package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:{{|\$\|)(.*?)(?:}}|\$\|)`)
var str = `"This {{@is}} a $|test$| string with $|@string$| delimiters {{as}} follows"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}