import re
regex = re.compile(r"\b(?![01]\b)\d{1,4}\b")
test_str = ("0\n"
"1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"10\n"
"99\n"
"101\n"
"999\n"
"9999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")