package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:7|0\d|\+94\d)\d{8}$`)
var str = `775645645
0775645645
+94775645645`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}