const regex = /^(?:7|0\d|\+94\d)\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:7|0\\d|\\+94\\d)\\d{8}$', 'gm')
const str = `775645645
0775645645
+94775645645`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}