$re = '/^RAM Statistics: *(?<Ram>\d+) *\/ *(?<Ratio>\d+)( *(?<InUse>\d+)=InUse)?( *(?<Peak>\d+)=Peak)?/m';
$str = 'RAM Statistics: 5954 / 8174 743=InUse 746=Peak
RAM Statistics: 5954 / 8174 746=Peak
RAM Statistics: 5954 / 8174 743=InUse
RAM Statistics: 5954 / 8174
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);