re = /^RAM Statistics: *(?<Ram>\d+) *\/ *(?<Ratio>\d+)( *(?<InUse>\d+)=InUse)?( *(?<Peak>\d+)=Peak)?/m
str = 'RAM Statistics: 5954 / 8174 743=InUse 746=Peak
RAM Statistics: 5954 / 8174 746=Peak
RAM Statistics: 5954 / 8174 743=InUse
RAM Statistics: 5954 / 8174
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end