$re = '/^((?!pdf|html|\/).)*\shttps/m';
$str = 'string.pdf https
string.html https
stringEndingWithSlash/ https
stringEndingWithoutSlash https';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);