re = /^((?!pdf|html|\/).)*\shttps/m
str = 'string.pdf https
string.html https
stringEndingWithSlash/ https
stringEndingWithoutSlash https'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end