# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+),(?=\d)/$1/gm;t' <<< "Text, 10,10 text, 40 text, 10,60
10,10,10"