package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\[1\])\[[\p{L}\s]+\]$`)
var str = `[1][الهه اردونی]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}