$re = '/^(\[1\])\[[\p{L}\s]+\]$/';
$str = '[1][الهه اردونی]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);