package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\[1\])(\[[\u0600-\u06FF\s]+\])$`)
var str = `[1][الهه اردونی]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}