$re = '/^(\[1\])(\[[\u0600-\u06FF\s]+\])$/m';
$str = '[1][الهه اردونی]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);