import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?xml(.+?)\\?>";
final String string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
+ "<ns1:StudySQL_response xmlns:ns1=\"urn:global:cs:jdbc:study\">\n"
+ "<Statement_response>\n"
+ " <row>\n"
+ " <XMLTYPE.GETSTRINGVAL(MESSAGE)><study studypid="200">\n"
+ " <studyname>&quot;Immume Treat Phase3&quot;</studyname>\n"
+ " <statusCD>ongoing</statusCD>\n"
+ " <clinicalphase>III</clinicalphase>\n"
+ " <primaryIndication>for lung cancer</primaryIndication>\n"
+ " <startDate>2010-Jun-28</startDate>\n"
+ "</study>\n"
+ "</XMLTYPE.GETSTRINGVAL(MESSAGE)>\n"
+ " </row>\n"
+ " <row>\n"
+ " <XMLTYPE.GETSTRINGVAL(MESSAGE)><study studypid="201">\n"
+ " <studyname>&quot;ABPM Study&quot;</studyname>\n"
+ " <statusCD>on hold</statusCD>\n"
+ " <clinicalphase>III</clinicalphase>\n"
+ " <primaryIndication>skin cancel</primaryIndication>\n"
+ " <startDate>2015-Mar-08</startDate>\n"
+ "</study>\n"
+ "</XMLTYPE.GETSTRINGVAL(MESSAGE)>\n"
+ " </row>\n"
+ "</Statement_response>\n"
+ "</ns1:StudySQL_response>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}