# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\?xml(.+?)\?>"
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<ns1:StudySQL_response xmlns:ns1=\"urn:global:cs:jdbc:study\">\n"
"<Statement_response>\n"
" <row>\n"
" <XMLTYPE.GETSTRINGVAL(MESSAGE)><study studypid="200">\n"
" <studyname>&quot;Immume Treat Phase3&quot;</studyname>\n"
" <statusCD>ongoing</statusCD>\n"
" <clinicalphase>III</clinicalphase>\n"
" <primaryIndication>for lung cancer</primaryIndication>\n"
" <startDate>2010-Jun-28</startDate>\n"
"</study>\n"
"</XMLTYPE.GETSTRINGVAL(MESSAGE)>\n"
" </row>\n"
" <row>\n"
" <XMLTYPE.GETSTRINGVAL(MESSAGE)><study studypid="201">\n"
" <studyname>&quot;ABPM Study&quot;</studyname>\n"
" <statusCD>on hold</statusCD>\n"
" <clinicalphase>III</clinicalphase>\n"
" <primaryIndication>skin cancel</primaryIndication>\n"
" <startDate>2015-Mar-08</startDate>\n"
"</study>\n"
"</XMLTYPE.GETSTRINGVAL(MESSAGE)>\n"
" </row>\n"
"</Statement_response>\n"
"</ns1:StudySQL_response>\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.