$re = '/<START>((?s).*)(\s\s|<STOP>)/m';
$str = '<START> some text is here.
more text
unrelated text
<START> even more text.
text text
<STOP>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);