// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<START>((?s).*)(\s\s|<STOP>)").unwrap();
let string = "<START> some text is here.
more text
unrelated text
<START> even more text.
text text
<STOP>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}