# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.*[1-9])(?!0\d)(\d{0,3}(?:\.\d{1,2})?)$"
test_str = ("Should match: (if decimal exists, max 3 numbers before and 2 after.)\n"
".01\n"
".1\n"
"0.01\n"
"0.1\n"
"1\n"
"10\n"
"10.1\n"
"10.11\n"
"105.1\n"
"999.99\n"
"88.00\n\n"
"Should fail:\n"
"12345678.54\n"
"00564.5412\n"
"00.451\n"
"1.\n"
",25\n"
"..25\n"
"0025\n"
"01\n"
"00,25\n"
"0\n"
".0\n"
"0.001\n"
"999.001\n"
"e123.12\n"
"1000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.