package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[start\](.*?)\[stop\]`)
var str = `[start]test1[stop] [start]test2[stop][start]test3[stop]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}