re = /\[start\](.*?)\[stop\]/
str = '[start]test1[stop] [start]test2[stop][start]test3[stop]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end