package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/Date\((\-?\d*?)([\+\-]\d*)?\)\/`)
var str = `/Date(2333432434+0100)/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}