$re = '/\/Date\((\-?\d*?)([\+\-]\d*)?\)\//';
$str = '/Date(2333432434+0100)/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);