import re
regex = re.compile(r"^(?<ip>[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}).*(?<mac>..:..:..:..:..:..)\s*.\s*(?<interface>.*)$", flags=re.MULTILINE)
test_str = ("192.168.87.2 0x1 0x2 0f:50:56:e3:9e:6a * wlan0\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")