re = /^(?<ip>[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}).*(?<mac>..:..:..:..:..:..)\s*.\s*(?<interface>.*)$/m
str = '192.168.87.2 0x1 0x2 0f:50:56:e3:9e:6a * wlan0
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end