using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<arg>(?<key>\w+)+=(?<quote>)(?<value>(?:[^\k<quote>]|(?<=\\)\k<quote>)+\k<quote>))";
string input = @"arg=""value"" arg='value' arg=`value` arg=""value 'value'"" arg='value \'value\' value' arg=""value \""value\"" value"" arg=`value \`value\ value`";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}