re = /(?<arg>(?<key>\w+)+=(?<quote>)(?<value>(?:[^\k<quote>]|(?<=\\)\k<quote>)+\k<quote>))/
str = 'arg="value" arg=\'value\' arg=`value` arg="value \'value\'" arg=\'value \\\'value\\\' value\' arg="value \\"value\\" value" arg=`value \\`value\\ value`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end