import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<arg>(?<key>\\w+)=(?<quote>['\"`]?)(?<value>(?:(?!\\k<quote>)[^\\\\])*(?:\\\\[\\s\\S](?:(?!\\k<quote>)[^\\\\])*)*)\\k<quote>)";
final String string = "arg=\"value\" arg='value' arg=`value` arg=\"value 'value'\" arg='value \\'value\\' value' arg=\"value \\\"value\\\" value\" arg=`value \\`value\\ value`";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}