$re = '/(?<arg>(?<key>\w+)=(?<quote>[\'"`]?)(?<value>(?:(?!\k<quote>)[^\\\\])*(?:\\\\[\s\S](?:(?!\k<quote>)[^\\\\])*)*)\k<quote>)/';
$str = 'arg="value" arg=\'value\' arg=`value` arg="value \'value\'" arg=\'value \\\'value\\\' value\' arg="value \\"value\\" value" arg=`value \\`value\\ value`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);