package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{, 8}`)
var str = `$23
23$
1000сум
сум1000
сум 1000
1000 сум
1000000000 сум`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}