$re = '/\d{, 8}/m';
$str = '$23
23$
1000сум
сум1000
сум 1000
1000 сум
1000000000 сум';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);