#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{2}.\d{2}.\d{2})(?:.+(\w{3}))?.+\w{3}.+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+(\d{2}.\d{2}.\d{2}).+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})"
Local $sString = "***ÄNDERUNG ***" & @CRLF & _
"NEU:11.04.15 DUS AB 2646 13:15 16:25" & @CRLF & _
" 18.04.15 FNC DUS AB 2647 17:15" & @CRLF & _
" FNC027 PESTANA CARLTON MADEIRA 9004-531 FUNCHAL" & @CRLF & _
" 1 DO-MEERBLICK F" & @CRLF & _
"F365474 HERR PETERS, HANS O 03.01.15" & @CRLF & _
"LANGZEITERMÄSSIGUNG 10%" & @CRLF & _
"SPO-JAN_SALES 20%" & @CRLF & _
"FRÜHBUCHER 10%" & @CRLF & _
"INKL. REISELEITUNG UND TRANSFER AB/BIS" & @CRLF & _
"FLUGHAFEN" & @CRLF & _
"Zimmer in ruhiger Lage" & @CRLF & _
"(unverbindlicher Kundenwunsch)" & @CRLF & _
"NEU:" & @CRLF & _
"F365474 FRAU PETERS, ULRIKE O 03.01.15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")