import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}.\\d{2}.\\d{2})(?:.+(\\w{3}))?.+\\w{3}.+(\\w{2}\\s\\d{4}).+(\\d{2}:\\d{2}\\n).+(\\d{2}.\\d{2}.\\d{2}).+(\\w{2}\\s\\d{4}).+(\\d{2}:\\d{2}\\n).+((FNC|PXO)\\d{3})";
final String string = "***ÄNDERUNG ***\n"
+ "NEU:11.04.15 DUS AB 2646 13:15 16:25\n"
+ " 18.04.15 FNC DUS AB 2647 17:15\n"
+ " FNC027 PESTANA CARLTON MADEIRA 9004-531 FUNCHAL\n"
+ " 1 DO-MEERBLICK F\n"
+ "F365474 HERR PETERS, HANS O 03.01.15\n"
+ "LANGZEITERMÄSSIGUNG 10%\n"
+ "SPO-JAN_SALES 20%\n"
+ "FRÜHBUCHER 10%\n"
+ "INKL. REISELEITUNG UND TRANSFER AB/BIS\n"
+ "FLUGHAFEN\n"
+ "Zimmer in ruhiger Lage\n"
+ "(unverbindlicher Kundenwunsch)\n"
+ "NEU:\n"
+ "F365474 FRAU PETERS, ULRIKE O 03.01.15";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}